Results 1 to 4 of 4
  1. #1
    Junior Member
    Join Date
    Nov 2015
    Posts
    26
    Thanks
    0
    Thanked 0 Times in 0 Posts

    Angry mba 820-3209 water damage. fan spining but nothing in the screem

    hi im working in mba 820-3209 with water damage .. i fix ppbus_g3h rail and now i can get 8.6v in ppbus_g3h rail.. the fan is spining. the rest of the rail are ok.i have green and orange light in the charger, the battery charger but no chime, nothing in the screen and the microprocessor is very very hot. any body have an idea where is the problem.. where i can start it ....? thanks

  2. #2
    Senior Member
    Join Date
    Jul 2016
    Posts
    140
    Thanks
    8
    Thanked 31 Times in 14 Posts

    Re: mba 820-3209 water damage. fan spining but nothing in the screem

    Hi,

    on this boards there is often a short from the mosfets creating the power for the CPU. Was there a short from the mosfets?

  3. #3
    VIP Member
    Join Date
    Nov 2014
    Location
    UK
    Posts
    1,122
    Thanks
    245
    Thanked 177 Times in 151 Posts

    Re: mba 820-3209 water damage. fan spining but nothing in the screem

    Can you perform an SMC reset to make sure the volume level is reset.
    Also check screen is powered and communication lines are OK.

  4. #4
    Junior Member
    Join Date
    Nov 2015
    Posts
    26
    Thanks
    0
    Thanked 0 Times in 0 Posts

    Re: mba 820-3209 water damage. fan spining but nothing in the screem

    Mostfet what I check with multimeter.....i check allí raíl with the multimeter and....They seemed to be well....only fix u7000. I change it for another new one..the old u7000 shorted to ground...
    Last edited by Carlosqg76; 07-05-2016 at 02:16 PM.

 

 

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •