Results 1 to 9 of 9
  1. #1
    Member
    Join Date
    Jun 2017
    Posts
    30
    Thanks
    5
    Thanked 0 Times in 0 Posts

    A1502 820-3476 strange bahaviour

    Hi,
    I've got a Macbook A1502 (2014) 820-3476 which when connected to MagSafe shows a green light for about 2s, then nothing, then red light and sometimes this red light stays for a while and Macbook loads to the Desktop. It starts even when lid is closed. Few seconds later it just turns off like it was a dead battery without charger. Baterry shows 0% and charging for that moment it stays on desktop.

    When I unpluged the battery Macbook turns on, fan spins for a while and stops (famous quarter fan spin I suppose). Then again and again.

    Where should I start first?
    My guess it starts because it has just a little energy left in battery, and it's even charging for that few seconds. Then it just shutdown because of no juice left.

    Can I measure voltage on power rails even without magsafe properly giving power?

    Thanks in advance for any suggestions and help.

    Kind regards,
    Raul

  2. #2
    Senior Member
    Join Date
    Aug 2015
    Posts
    341
    Thanks
    27
    Thanked 62 Times in 41 Posts

    Re: A1502 820-3476 strange bahaviour

    Well, first check the PPBUS_G3H voltage. Do this with the battery disconnected.

    Any history on liquid damage?

  3. #3
    Member
    Join Date
    Jun 2017
    Posts
    30
    Thanks
    5
    Thanked 0 Times in 0 Posts

    Re: A1502 820-3476 strange bahaviour

    Only told that it was liquid damaged. Will look for any signs of liquid damage under a microscope (I don't see anything o the first look without magnify) . I will check PPBUS_G3H, thanks

    DCIN Board voltag seems ok - 16,42V on pin 1 and 2.
    AdapterSense line is 2,9V

    Measurements:
    R7005:
    PIN 1 - PPBUS_G3H - 10,9V (low!) going to 0V with 3,8V being shown for a while
    PIN 2 - PPBUS_G3H_R - 10,9V, going down as pin 1

    T7005:
    PIN 1 - 16,2V and going up to 16,3V

    C7005 - cap missing!
    PIN 1 - 16,4V
    PIN 2 - GND

    So I need this capacitor for sure, but is it that important? I thought it's for smoothing voltage, probably something else is bad too.
    Last edited by Rauliki; 06-14-2019 at 04:16 AM.

  4. #4
    Senior Member
    Join Date
    Aug 2015
    Posts
    341
    Thanks
    27
    Thanked 62 Times in 41 Posts

    Re: A1502 820-3476 strange bahaviour

    C7005 is NO STUFF, so it means it should be missing from the final board version.

    You have problems with the PPBUS_G3H

    Check current sense resistors near the U7100.
    These would be:
    R7121
    R7122
    and
    R7151
    R7152

  5. The Following User Says Thank You to mitchW For This Useful Post:

    Rauliki (06-20-2019)

  6. #5
    Member
    Join Date
    Jun 2017
    Posts
    30
    Thanks
    5
    Thanked 0 Times in 0 Posts

    Re: A1502 820-3476 strange bahaviour

    Thanks, I will

  7. #6
    Member
    Join Date
    Jun 2017
    Posts
    30
    Thanks
    5
    Thanked 0 Times in 0 Posts

    Re: A1502 820-3476 strange bahaviour

    Wow, you were spot on.
    It was R7152, there was a slight water damage.
    It was almost my first repair (changing big cap on Macbook 2010 15 it's really a piece of cake compared to those small resistors).
    I will test it if it works, maybe something else is broken but for now it boots and seems to charge the battery
    Thank you kindly MitchW!

  8. #7
    Senior Member
    Join Date
    Aug 2015
    Posts
    341
    Thanks
    27
    Thanked 62 Times in 41 Posts

    Re: A1502 820-3476 strange bahaviour

    Nice! This is quite a common fault on liquid damaged boards, sometimes also when ISL dies takes few of these resistors with.

    And yes, for the 0201 size components you almost require a microscope to solder.

  9. #8
    Member
    Join Date
    Jun 2017
    Posts
    30
    Thanks
    5
    Thanked 0 Times in 0 Posts

    Re: A1502 820-3476 strange bahaviour

    I used microscope. I would never try to microsolder withut it. Those resistor are very small (actually - 0402).
    It was corroded til the probe point, so I used a small magnetic wire. I tried to scrap it till the point but was afraid to do more damage.
    One thing that bothers me is when I open pages (youtube) the cpu gets hot very fast (70C) and fans goes full speed for few seconds.
    I changed the thermal paste to new (Arctic MX-4) but I guess it's the way Macbooks are. Will try better paste.
    Again, thanks. it was very positive experience, I think I love those 13 Macbooks A1502 (Mid 2014), there are easy to get board off case.

  10. #9
    Senior Member
    Join Date
    Aug 2015
    Posts
    341
    Thanks
    27
    Thanked 62 Times in 41 Posts

    Re: A1502 820-3476 strange bahaviour

    Fan should be off until the temperature reaches 65-70 deg. C. Then it should start, but initially run slowly. If it goes full blast, then you most likely have a problem somewhere.

    See if you are getting full heatsink contact with the CPU die. Best thing is to clean the old thermal paste, apply a thin film of paste on the CPU die (spread it evenly), install the heatsink back, and remove it. Then examine the heatsink if the paste has spread evenly and if there is an imprint of the CPU die.
    I had it happen that the heatsink was bent and only half of the CPU die had a proper contact with the heatsink.

    For the thermal paste, I am using Arctic Silver 5 for the last 10 years, but MX-4 should be also a very good performer.

 

 

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •