Results 1 to 6 of 6
  1. #1
    Junior Member
    Join Date
    Mar 2017
    Posts
    3
    Thanks
    0
    Thanked 0 Times in 0 Posts

    Question 820-3115 PPBUS_G3H still missing after ISL rework

    Hi Guy,

    I'm going crazy with this board, it had an ISL failure ( green light, no start, no charge ), I replaced the ISL( 2 times, same behavior), fix the current sense circuit and test the switching MOSFETs, so should be fine.
    There is still green light and no PPBUS_G3H, I meansure every resistor and I compared nearly all pin with my another 820-3115 board ( which is working fine ) on diode mode readings (red on GND).
    It is seem somehow the high side driving (q7030) is not working properly. Maybe the boost circuit ( I replaced C7025) or something, but when the ISL try to turn on the q7030 mosfet it is driving with a weak and distorted signal.
    The green light on the charger is pulsing periodically and L7030 make a ticking noise.
    Here is a link of my measurements:

    On the first picture I measured the q7030 gate (blue) and source (CHGR_PHASE pin of ISL)
    As you can seen on the picture the ISL try to drive the gate high but it is only a 7.8v at peek, and not look like a PWM signal, it is just ringing.

    On the second picture I measured the q7035 (blue) and the boost voltage (pin25 of ISL) and it is look bad too.

    I looking for advice, thanks

    UI.: If I remove the fuse F7040, and I supply the system with external 12v and I plug the charge in, I get fanspin, so there is no short on the board.

  2. #2
    Junior Member
    Join Date
    Mar 2017
    Posts
    3
    Thanks
    0
    Thanked 0 Times in 0 Posts

    Re: 820-3115 PPBUS_G3H still missing after ISL rework

    Can anybody know how I post my link? It is say I have no permissions

  3. #3
    VIP Member
    Join Date
    Nov 2014
    Location
    UK
    Posts
    1,105
    Thanks
    240
    Thanked 176 Times in 150 Posts

    Re: 820-3115 PPBUS_G3H still missing after ISL rework

    Quote Originally Posted by zoon8181 [Only Registered and Activated Users Can See Links. Click Here To Register...]
    Can anybody know how I post my link? It is say I have no permissions
    I think its because you're a fairly new member.
    Can an admin allow access please?

  4. #4
    Senior Member
    Join Date
    Aug 2015
    Posts
    364
    Thanks
    30
    Thanked 67 Times in 46 Posts

    Re: 820-3115 PPBUS_G3H still missing after ISL rework

    I would check your soldering of the ISL chip. I had it happen that the solder job was not good on these U7000s and therefore no right voltage was generated.
    I would also check for shorts on output, but as you injected the voltage and it works, then it is most likely okay.

    Next, check current sense resistors. Also check all the connections, perhaps you have a blown via somewhere.

  5. #5
    VIP Member
    Join Date
    Jan 2016
    Location
    Budapest, Hungary
    Posts
    652
    Thanks
    12
    Thanked 139 Times in 113 Posts

    Re: 820-3115 PPBUS_G3H still missing after ISL rework

    Clicking 3115 is never a good sign. Inspect audio IC circuit caps for shorts.

  6. #6
    Junior Member
    Join Date
    Mar 2017
    Posts
    3
    Thanks
    0
    Thanked 0 Times in 0 Posts

    Re: 820-3115 PPBUS_G3H still missing after ISL rework

    Thank you. I have a working 820-3115 board, so I will check all the pins, one by one with diode mode measurement between the 2 boards.
    I fixed the current sensing (both), and yes maybe the soldering is bad, I have a cheaper hot air station so I give a second try to solder it properly.

 

 

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •