Results 1 to 4 of 4
  1. #1
    Senior Member
    Join Date
    Aug 2015
    Posts
    364
    Thanks
    30
    Thanked 67 Times in 46 Posts

    820-3115 no LCD detected, missing LCD_IG_PWR_EN

    I just got another butchered one, luckily the logic board was not touched much, but other things were (camera connector broken off, missing speaker, etc.). Came from another shop.

    It was described as: "turned off mid use". No liquid damage. There is really no liquid damage anywhere to be seen.
    Found an error that caused PPBUS_G3H to be only 1.4V, open R7021 and R7022.
    Now I got a fan spin, a chime and a blinking question mark on external LCD. Booted it to OS, looks like it is working 100%.

    Except, the internal LCD is not detected.
    Checked the usual suspects, the L9004, R9009, R9008. All check good and the LCD is receiving 3.3V on the PP3V3_S0_LCD_F.

    But I am missing the PP3V3_S0_LCDVDD_SW_F. Traced it back and found the LCD_IG_PWR_EN is missing.
    This should be 3.3V, but it is 0V at all times. This comes from the PCH...

    The LCD is known good, tried it on another machine and it works.

    Any suggestions?

  2. #2
    Senior Member
    Join Date
    Oct 2014
    Posts
    156
    Thanks
    37
    Thanked 13 Times in 11 Posts

    Re: 820-3115 no LCD detected, missing LCD_IG_PWR_EN

    Do you have another PCH? I've been stumped on exact issue a few times in the past , pull one, reball and replace. When its removed check to see if you have continuity on that track from the bga pad LCD_IG_PWR_EN if not the board is done the via is broke.
    Last edited by John626; 07-29-2019 at 07:40 AM.

  3. #3
    Senior Member
    Join Date
    Aug 2015
    Posts
    364
    Thanks
    30
    Thanked 67 Times in 46 Posts

    Re: 820-3115 no LCD detected, missing LCD_IG_PWR_EN

    I just ordered one, should be here in about a week or two. We will see if it will help.

    I reflashed the BIOS with a known good image, the situation remained the same. I put the old image back.
    So I guess it is going to be a PCH issue.

    I also measured this line to ground and it is 89.5K to ground, exactly the same on a working board.

    Any more suggestions? My bet is on PCH, though..

  4. #4
    Senior Member
    Join Date
    Oct 2014
    Posts
    156
    Thanks
    37
    Thanked 13 Times in 11 Posts

    Re: 820-3115 no LCD detected, missing LCD_IG_PWR_EN

    I was hoping you had a donor first , I had 2 just like yours the 1 I could not fix it seemed the track or via inside was blown the other worked after the PCH change , I needed to flash the bios because of the new PCH it acted crazy at times.
    I'm just hoping since you ordered the Chip your track is ok I've seen backlight issues where it lit the board up like a firework and also seen it short the entire board to ground.
    You could try diagnosing the PCH I did but it seemed senseless I was missing LCD_IG_PWR_EN so I figured swap it out .
    Last edited by John626; 08-01-2019 at 02:25 AM.

 

 

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •